БЕЗОПАСНАЯ архитектура оболочки
Опубликовано: 16 Сентября, 2022
В этой статье мы обсудим обзор протокола SSH (Secure Shell), а затем сосредоточимся в основном на его архитектурной части и объясним его работу. Давайте обсудим это один за другим.
SSH (протокол защищенной оболочки):
- Это сетевой протокол научной дисциплины для оперативных сетевых служб в незащищенной сети.
- Он предназначен для замены незащищенного протокола, такого как -telnet, и небезопасных методов передачи файлов (например, FTP).
- Он использует дизайн потребительского сервера.
- Он использует криптографию с открытым ключом/криптографию с асимметричным ключом для демонстрации удаленного сервера. т.е. подтвердить свою личность на удаленном сервере.
Архитектура SSH:
Протокол SSH-2 имеет внутреннюю структуру (определенную в RFC 4251) с хорошо разделенными уровнями, а именно следующим образом.

- Транспортный уровень (RFC 4253) –
Обычно он работает на базе TCP/IP. Этот уровень обрабатывает начальный обмен ключами между поставщиком и получателем. - Уровень аутентификации пользователя (RFC 4252) –
Этот уровень обрабатывает аутентификацию потребителя и предоставляет ряд способов аутентификации. Его потребительское агентство SSH ООН отвечает, когда пользователь запрашивает пароль, а не сервер. Сервер просто отвечает на запросы аутентификации клиента. К широко используемым способам аутентификации пользователей относятся следующие. - Лозунг –
Прозрачное средство для аутентификации по паролю, а также средство, позволяющее изменять пароль. Существует всего несколько программ, в которых агентства ООН применяют эту методологию. - Открытый ключ –
Метод аутентификации на основе открытого ключа, иногда поддерживающий минимум пар ключей DSA, ECDSA или RSA, с различными реализациями, совместно поддерживающими сертификаты X.509. - Интерактивная клавиатура (RFC 4256) -
Во время этого сервер отправляет одно или несколько приглашений для ввода данных, и поэтому потребитель отображает их и отправляет обратно ответы, введенные пользователем. Acustomed предлагает одноразовую аутентификацию по паролю, такую как S/Key или SecurID. - Аутентификация GSSAPI —
Это выполняет внешние механизмы неправильной обработки аутентификации SSH, такие как Kerberos 5 или NTLM, предоставляя возможность единого входа для сеансов SSH. Эти способы иногда применяются в промышленных реализациях SSH для использования в организациях. - Ассоциативный уровень (RFC 4254) –
Во время такого представления о каналах, запросах каналов и международных запросах предоставляются услуги SSH. В одной SSH-ассоциации будет одновременно размещаться несколько каналов, знания будут передаваться в обе стороны. Запросы канала используются для внеполосной передачи специфичных для канала знаний, таких как измененный размер окна терминала или код выхода метода на стороне сервера. - DNS-запись SSHFP (RFC 4255) —
Он предоставляет отпечатки пальцев открытого ключа хоста, чтобы помочь подтвердить легитимность хоста.
Примечание -
Несмотря на стандартные идеи, SSH не является реализацией Telnet на уровне ассоциированной степени с криптографией, предоставляемой Secure Sockets Layer (SSL).